using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"<[^""]*class=""[^""]*(?<=""|\s)marginRight(?=""|\s[^""]*)""[^""]*href=""(?<url>([^?][^\d+]*(?<number>\d+))[^""]*)""";
        string input = @"<span class=""nav-next-btn nohistory FloatRight"">
			 
				<span class=""nav-next-btn nohistory marginRight"">
					<a href=""http://www.mudah.my/Pahang/nike-for-sale?o=2&q=nike&so=1&th=1"" title=""Go to next page"">
						Next ›
					</a>
				</span>
			
			
	
			
				<a href=""http://www.mudah.my/Pahang/nike-for-sale?o=5&q=nike&so=1&th=1"" title=""Go to last page"">
					Last »
				</a>
			   		
			                                                     
		</span>";
        
        foreach (Match m in Regex.Matches(input, pattern))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}