re = /<[^"]*class="[^"]*(?<="|\s)marginRight(?="|\s[^"]*)"[^"]*href="(?<url>([^?][^\d+]*(?<number>\d+))[^"]*)"/
str = '<span class="nav-next-btn nohistory FloatRight">
<span class="nav-next-btn nohistory marginRight">
<a href="http://www.mudah.my/Pahang/nike-for-sale?o=2&q=nike&so=1&th=1" title="Go to next page">
Next ›
</a>
</span>
<a href="http://www.mudah.my/Pahang/nike-for-sale?o=5&q=nike&so=1&th=1" title="Go to last page">
Last »
</a>
</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end