#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https.*[^doc]$"
Local $sString = "http://example.com/test" & @CRLF & _
"https://example.com/test" & @CRLF & _
"https://example.com/test/123" & @CRLF & _
"http://example.com/doc" & @CRLF & _
"https://example.com/testik/doc" & @CRLF & _
"https://example.com/testik/doc/api" & @CRLF & _
"/" & @CRLF & _
"#"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")