// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https.*[^doc]$").unwrap();
let string = "http://example.com/test
https://example.com/test
https://example.com/test/123
http://example.com/doc
https://example.com/testik/doc
https://example.com/testik/doc/api
/
#";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}