const regex = /^https.*[^doc]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https.*[^doc]$', 'gm')
const str = `http://example.com/test
https://example.com/test
https://example.com/test/123
http://example.com/doc
https://example.com/testik/doc
https://example.com/testik/doc/api
/
#`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}