re = /^https.*[^doc]$/m
str = 'http://example.com/test
https://example.com/test
https://example.com/test/123
http://example.com/doc
https://example.com/testik/doc
https://example.com/testik/doc/api
/
#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end