using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https.*[^doc]$";
string input = @"http://example.com/test
https://example.com/test
https://example.com/test/123
http://example.com/doc
https://example.com/testik/doc
https://example.com/testik/doc/api
/
#";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}