#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z]{2} \d{3,6})(\.\d*)?( [A-Z]\d+)+([\.\d\-\(\)\+]*)?"
Local $sString = "GL 5864 H598 M8-2+3" & @CRLF & _
"ZN 2455 B927(5.0)" & @CRLF & _
"LI 21900 H592" & @CRLF & _
"LH 42800.2004 H7" & @CRLF & _
"LI 99999 T454 Thomas" & @CRLF & _
"KI 5234 D65.2002" & @CRLF & _
"CB 3700 N664(3)" & @CRLF & _
"UQ 1000 B726 K9(7)E(3)" & @CRLF & _
"FH 15900 V878-2(3)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")