// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z]{2} \d{3,6})(\.\d*)?( [A-Z]\d+)+([\.\d\-\(\)\+]*)?").unwrap();
let string = "GL 5864 H598 M8-2+3
ZN 2455 B927(5.0)
LI 21900 H592
LH 42800.2004 H7
LI 99999 T454 Thomas
KI 5234 D65.2002
CB 3700 N664(3)
UQ 1000 B726 K9(7)E(3)
FH 15900 V878-2(3)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}