import Foundation
let pattern = #"([A-Z]{2} \d{3,6})(\.\d*)?( [A-Z]\d+)+([\.\d\-\(\)\+]*)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
GL 5864 H598 M8-2+3
ZN 2455 B927(5.0)
LI 21900 H592
LH 42800.2004 H7
LI 99999 T454 Thomas
KI 5234 D65.2002
CB 3700 N664(3)
UQ 1000 B726 K9(7)E(3)
FH 15900 V878-2(3)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)