using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bA[a-z]{6}\b";
string input = @"Aabcdef Aabcdefg Aabcde Aabcdef
Aabcdef Aabcdefg Aabcde Aabcdef ";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}