// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\bA[a-z]{6}\b").unwrap();
let string = "Aabcdef Aabcdefg Aabcde Aabcdef
Aabcdef Aabcdefg Aabcde Aabcdef ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}