re = /\bA[a-z]{6}\b/
str = 'Aabcdef Aabcdefg Aabcde Aabcdef
Aabcdef Aabcdefg Aabcde Aabcdef '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end