$re = '/\bA[a-z]{6}\b/s';
$str = 'Aabcdef Aabcdefg Aabcde Aabcdef
Aabcdef Aabcdefg Aabcde Aabcdef ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);