package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\bA[a-z]{6}\b`)
var str = `Aabcdef Aabcdefg Aabcde Aabcdef
Aabcdef Aabcdefg Aabcde Aabcdef `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}