const regex = /\h+(?=[A-Z][a-z]*: )/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h+(?=[A-Z][a-z]*: )', 'gm')
const str = `Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);