import Foundation
let pattern = #"\h+(?=[A-Z][a-z]*: )"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)