use strict;
my $str = 'Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook';
my $regex = qr/\h+(?=[A-Z][a-z]*: )/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";