$re = '/\h+(?=[A-Z][a-z]*: )/m';
$str = 'Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;