re = /\h+(?=[A-Z][a-z]*: )/m
str = 'Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result