#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=<div\sclass="test">\n).*(?=<\/div>)"
Local $sString = "<div class="test">" & @CRLF & _
" <div>" & @CRLF & _
" <div>Some text 1</div> " & @CRLF & _
" <div>Image content 2</div>" & @CRLF & _
" </div>" & @CRLF & _
" <div>" & @CRLF & _
" <div>Some text 2</div> " & @CRLF & _
" <div>Image content 2</div>" & @CRLF & _
" </div>" & @CRLF & _
" ...." & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")