const regex = /(?s)(?<=<div\sclass="test">\n).*(?=<\/div>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(?<=<div\\sclass="test">\\n).*(?=<\\\/div>)', '')
const str = `<div class="test">
<div>
<div>Some text 1</div>
<div>Image content 2</div>
</div>
<div>
<div>Some text 2</div>
<div>Image content 2</div>
</div>
....
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}