re = /(?s)(?<=<div\sclass="test">\n).*(?=<\/div>)/
str = '<div class="test">
<div>
<div>Some text 1</div>
<div>Image content 2</div>
</div>
<div>
<div>Some text 2</div>
<div>Image content 2</div>
</div>
....
</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end