import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?<=<div\\sclass=\"test\">\\n).*(?=<\\/div>)";
final String string = "<div class=\"test\">\n"
+ " <div>\n"
+ " <div>Some text 1</div> \n"
+ " <div>Image content 2</div>\n"
+ " </div>\n"
+ " <div>\n"
+ " <div>Some text 2</div> \n"
+ " <div>Image content 2</div>\n"
+ " </div>\n"
+ " ....\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}