use strict;
my $str = '<div class="test">
<div>
<div>Some text 1</div>
<div>Image content 2</div>
</div>
<div>
<div>Some text 2</div>
<div>Image content 2</div>
</div>
....
</div>';
my $regex = qr/(?s)(?<=<div\sclass="test">\n).*(?=<\/div>)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}