using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^\P{L}*)(?<!\d)\d{2,10}(?!\d)";
string input = @"2216101225 /ROC/PL FCT DIN 24.03.2022 PL ERBICIDE
++++ 2216101225 :: 23467 -- 432423423423423 444/ROC/PL FCT DIN 24.03.2022 PL ERBICIDE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}