re = /(?<=^\P{L}*)(?<!\d)\d{2,10}(?!\d)/m
str = '2216101225 /ROC/PL FCT DIN 24.03.2022 PL ERBICIDE
++++ 2216101225 :: 23467 -- 432423423423423 444/ROC/PL FCT DIN 24.03.2022 PL ERBICIDE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end