const regex = new RegExp('(?<=^\\P{L}*)(?<!\\d)\\d{2,10}(?!\\d)', 'gm')
const str = `2216101225 /ROC/PL FCT DIN 24.03.2022 PL ERBICIDE
++++ 2216101225 :: 23467 -- 432423423423423 444/ROC/PL FCT DIN 24.03.2022 PL ERBICIDE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}