import Foundation
let pattern = #"(?<=^\P{L}*)(?<!\d)\d{2,10}(?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2216101225 /ROC/PL FCT DIN 24.03.2022 PL ERBICIDE
++++ 2216101225 :: 23467 -- 432423423423423 444/ROC/PL FCT DIN 24.03.2022 PL ERBICIDE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)