package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)cron\((([0-9]{1,2}|\*)\,?\/?)+\s(([0-9]{1,2}|\*)\,?)+\s(([0-9]{1,2}|\*|\?)\,?)+\s(([0-9]{1,2}|\*|\?|(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))\,?)+\s(([0-9]{1,2}[FL]?|\*|\?|(SAT|SUN|MON|TUE|WED|THU|FRI)\#?[0-9]?)\,?\-?)+\s(([0-9]{1,4}|\*)\,?\-?)+\)`)
var str = `cron(0 2 ? * SAT *)
cron(0 12 * * ? *)
cron(5,35 14 * * ? *)
cron(15 10 ? * 6L 2002-2005)
cron(0 2 ? * SAT#3 *)
cron(* * ? * SAT#3 *)
cron(0/5 5 ? JAN 1-5 2022)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}