$re = '/cron\((([0-9]{1,2}|\*)\,?\/?)+\s(([0-9]{1,2}|\*)\,?)+\s(([0-9]{1,2}|\*|\?)\,?)+\s(([0-9]{1,2}|\*|\?|(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))\,?)+\s(([0-9]{1,2}[FL]?|\*|\?|(SAT|SUN|MON|TUE|WED|THU|FRI)\#?[0-9]?)\,?\-?)+\s(([0-9]{1,4}|\*)\,?\-?)+\)/m';
$str = 'cron(0 2 ? * SAT *)
cron(0 12 * * ? *)
cron(5,35 14 * * ? *)
cron(15 10 ? * 6L 2002-2005)
cron(0 2 ? * SAT#3 *)
cron(* * ? * SAT#3 *)
cron(0/5 5 ? JAN 1-5 2022)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);