import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "cron\\((([0-9]{1,2}|\\*)\\,?\\/?)+\\s(([0-9]{1,2}|\\*)\\,?)+\\s(([0-9]{1,2}|\\*|\\?)\\,?)+\\s(([0-9]{1,2}|\\*|\\?|(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))\\,?)+\\s(([0-9]{1,2}[FL]?|\\*|\\?|(SAT|SUN|MON|TUE|WED|THU|FRI)\\#?[0-9]?)\\,?\\-?)+\\s(([0-9]{1,4}|\\*)\\,?\\-?)+\\)";
final String string = "cron(0 2 ? * SAT *)\n"
+ "cron(0 12 * * ? *)\n"
+ "cron(5,35 14 * * ? *)\n"
+ "cron(15 10 ? * 6L 2002-2005)\n"
+ "cron(0 2 ? * SAT#3 *)\n"
+ "cron(* * ? * SAT#3 *)\n"
+ "cron(0/5 5 ? JAN 1-5 2022)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}