import re
regex = re.compile(r"cron\((([0-9]{1,2}|\*)\,?\/?)+\s(([0-9]{1,2}|\*)\,?)+\s(([0-9]{1,2}|\*|\?)\,?)+\s(([0-9]{1,2}|\*|\?|(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))\,?)+\s(([0-9]{1,2}[FL]?|\*|\?|(SAT|SUN|MON|TUE|WED|THU|FRI)\#?[0-9]?)\,?\-?)+\s(([0-9]{1,4}|\*)\,?\-?)+\)", flags=re.MULTILINE)
test_str = ("cron(0 2 ? * SAT *)\n"
"cron(0 12 * * ? *)\n"
"cron(5,35 14 * * ? *)\n"
"cron(15 10 ? * 6L 2002-2005)\n"
"cron(0 2 ? * SAT#3 *)\n"
"cron(* * ? * SAT#3 *)\n"
"cron(0/5 5 ? JAN 1-5 2022)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")