const regex = /cron\((([0-9]{1,2}|\*)\,?\/?)+\s(([0-9]{1,2}|\*)\,?)+\s(([0-9]{1,2}|\*|\?)\,?)+\s(([0-9]{1,2}|\*|\?|(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))\,?)+\s(([0-9]{1,2}[FL]?|\*|\?|(SAT|SUN|MON|TUE|WED|THU|FRI)\#?[0-9]?)\,?\-?)+\s(([0-9]{1,4}|\*)\,?\-?)+\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('cron\\((([0-9]{1,2}|\\*)\\,?\\\/?)+\\s(([0-9]{1,2}|\\*)\\,?)+\\s(([0-9]{1,2}|\\*|\\?)\\,?)+\\s(([0-9]{1,2}|\\*|\\?|(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))\\,?)+\\s(([0-9]{1,2}[FL]?|\\*|\\?|(SAT|SUN|MON|TUE|WED|THU|FRI)\\#?[0-9]?)\\,?\\-?)+\\s(([0-9]{1,4}|\\*)\\,?\\-?)+\\)', 'gm')
const str = `cron(0 2 ? * SAT *)
cron(0 12 * * ? *)
cron(5,35 14 * * ? *)
cron(15 10 ? * 6L 2002-2005)
cron(0 2 ? * SAT#3 *)
cron(* * ? * SAT#3 *)
cron(0/5 5 ? JAN 1-5 2022)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}