# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.{6})(.{6})(.{6})/$1 $2 $3/gm;t' <<< "abcdefabcdefabcdef"