using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.{6})(.{6})(.{6})";
string substitution = @"$1 $2 $3";
string input = @"abcdefabcdefabcdef";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}