package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.{6})(.{6})(.{6})`)
var str = `abcdefabcdefabcdef`
var substitution = "$1 $2 $3"
fmt.Println(re.ReplaceAllString(str, substitution))
}