const regex = /(.{6})(.{6})(.{6})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.{6})(.{6})(.{6})', 'gm')
const str = `abcdefabcdefabcdef`;
const subst = `$1 $2 $3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);