$re = '/(.{6})(.{6})(.{6})/m';
$str = 'abcdefabcdefabcdef';
$subst = "$1 $2 $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;