using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0*(\d+(?:\.(?:(?!0+$)\d)+)?).*$";
string substitution = @"$1";
string input = @"0.0
1.230
00123
012.30400
0102
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}