import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0*(\\d+(?:\\.(?:(?!0+$)\\d)+)?).*$";
final String string = "0.0\n"
+ "1.230\n"
+ "00123\n"
+ "012.30400\n"
+ "0102\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}