const regex = /^0*(\d+(?:\.(?:(?!0+$)\d)+)?).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0*(\\d+(?:\\.(?:(?!0+$)\\d)+)?).*$', 'gm')
const str = `0.0
1.230
00123
012.30400
0102
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);