$re = '/^0*(\d+(?:\.(?:(?!0+$)\d)+)?).*$/m';
$str = '0.0
1.230
00123
012.30400
0102
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;