# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[A-Z][A-Z])[a-z]|(?<=[a-z])[A-Z]+/_\L$0/gm;t' <<< "parsingHTTPorSomeURLrequestToday
enhanceThisGold
thisIsCOOL
xP
anotherACRONYMiTest
loadedTHISupLIKEaMaDmAnS
NoReplacement
NONEok
None
none
n"