# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=[A-Z][A-Z])[a-z]|(?<=[a-z])[A-Z]+"
test_str = ("parsingHTTPorSomeURLrequestToday\n"
"enhanceThisGold\n"
"thisIsCOOL\n"
"xP\n"
"anotherACRONYMiTest\n"
"loadedTHISupLIKEaMaDmAnS\n"
"NoReplacement\n"
"NONEok\n"
"None\n"
"none\n"
"n")
subst = "_\\L$0"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.