re = /(?<=[A-Z][A-Z])[a-z]|(?<=[a-z])[A-Z]+/m
str = 'parsingHTTPorSomeURLrequestToday
enhanceThisGold
thisIsCOOL
xP
anotherACRONYMiTest
loadedTHISupLIKEaMaDmAnS
NoReplacement
NONEok
None
none
n'
subst = '_\\L$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result