#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[A-Z][A-Z])[a-z]|(?<=[a-z])[A-Z]+"
Local $sString = "parsingHTTPorSomeURLrequestToday" & @CRLF & _
"enhanceThisGold" & @CRLF & _
"thisIsCOOL" & @CRLF & _
"xP" & @CRLF & _
"anotherACRONYMiTest" & @CRLF & _
"loadedTHISupLIKEaMaDmAnS" & @CRLF & _
"NoReplacement" & @CRLF & _
"NONEok" & @CRLF & _
"None" & @CRLF & _
"none" & @CRLF & _
"n"
Local $sSubst = "_\L$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)