use strict;
my $str = 'parsingHTTPorSomeURLrequestToday
enhanceThisGold
thisIsCOOL
xP
anotherACRONYMiTest
loadedTHISupLIKEaMaDmAnS
NoReplacement
NONEok
None
none
n';
my $regex = qr/(?<=[A-Z][A-Z])[a-z]|(?<=[a-z])[A-Z]+/mp;
my $subst = '_\\L$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";