#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\((?:[^()]++|(?R))*\)"
Local $sString = "(pop+corn)-bread+salt" & @CRLF & _
"(pop+corn+unicorn)-bread+salt+malt" & @CRLF & _
"(pop(+corn)+unicorn)-bread+salt+malt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")