using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?:[^()]++|(?R))*\)";
string input = @"(pop+corn)-bread+salt
(pop+corn+unicorn)-bread+salt+malt
(pop(+corn)+unicorn)-bread+salt+malt";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}